** インストール [#aea6e24c]
 
 - 後でバージョン違いのPHPを入れることもあるかもしれないので、/opt/php配下に入れる
 - enable-fastcgiを指定
  cd /usr/local/src
  wget http://jp.php.net/get/php-5.2.9.tar.bz2/from/this/mirror
  tar xjf php-5.2.9.tar.bz2
  cd php-5.2.9
  ./configure --enable-fastcgi --prefix=/opt/php-5.2.9
  make 
  make test
 
 - lighttpd.conf に、次の記述を追加
 
  ".php" => (
  (
     "socket" => "/tmp/php.socket",
     "bin-path" => "/opt/php-5.2.9/bin/php-cgi",
     "bin-environment" => (
       "PHP_FCGI_CHILDREN" => "16",
       "PHP_FCGI_MAX_REQUESTS" => "10000"
     ),
     "min-procs" => 1,
     "max-procs" => 1,
     "idle-timeout" => 20
   ))
 
 

トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS

アークウェブのサービスやソリューションはこちら